Digitally signing with a certificate that has strong protection enabled


When certificates have strong protection enabled, a PDF cannot be signed.


When digitally signing a PDF with a certificate that has strong protection enabled, one of the following occurs:



  • the code appears to hang and the PDF is not signed.

  • a dialog appears and the PDF is not signed.
    When running the digital signing code under a user who is not logged in, the dialog does not appear. Instead, the code appears to hang and is unable to sign the PDF.


Probable Cause


The PDF cannot be signed when the strong protection is enabled in the certificate.


Resolution


Disable strong protection for all certificates. 


To disable strong protection:



  1. Export the certificate.

  2. Reimport the certificate, making sure that Strong Protection is not selected.

  3. Attempt the digital signing again.